close.uri valid values

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

close.uri valid values

bruno.buzzi
Hi,

close.uri is not accepting the following configuration:
<property as="xs:string" name="oxf.fr.detail.close.uri.*.*"
value="http://gemstoneIP:8787/bpmflow-frontoffice?_s={//s}&amp;_k={//k}"/>

Where gemstoneIP is defined in hosts file (in Linux).

With a hardcoded ip value works ok:
http://192.168.29.142:8787/bpmflow-frontoffice?_s={//s}&amp;_k={//k}

Is this a bug or close.uri never accepted hostnames ?

The host name works ok on process.send property (the following works ok):
then send(replace = &quot;all&quot;, uri =
&quot;http://gemstoneIP:8787/orbeon-gemstone-api/processform&quot;)

regards,
bruno

--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

Alessandro  Vernet
Administrator
Hi Bruno,

Are you saying that you are using a `close` button? Then by default the
process for this button does a `navigate("oxf.fr.detail.close.uri")` (see
1st link below). When referring to a property, the value of the property is
taken as-is.

But when you use the `uri` parameter, it is taken as a value template (see
2nd link below), so instead of setting the `oxf.fr.detail.close.uri`
property, you could override the `oxf.fr.detail.process.close.*.*` process
to do what you need.

https://github.com/orbeon/orbeon-forms/blob/tag-release-2017.2-ce/src/main/resources/config/properties-form-runner.xml#L256
https://doc.orbeon.com/form-runner/advanced/buttons-and-processes/actions-form-runner.html#navigate

You'll let me know if this works for you.

Alex

-----
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

bruno.buzzi
Alex,

Thanks for the tip. Fixed rewritting the close process:

<property as="xs:string" name="oxf.fr.detail.process.close.*.*">
                     navigate(uri =
"http://gemstoneIP:8787/bpmflow-frontoffice?_s={//s}&_k={//k}")
</property>

regards,
bruno

--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

bruno.buzzi
This post was updated on .
Hi,

Just for the record url parameter separator ampersand (&) must be escaped (& amp;).

<property as="xs:string" name="oxf.fr.detail.process.close.*.*">
                     navigate(uri =
"http://gemstoneIP:8787/bpmflow-frontoffice?_s={//s}&_k={//k}")
</property>

--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to orbeon+unsubscribe@googlegroups.com.
To post to this group, send email to orbeon@googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

bruno.buzzi
Hi,

Well this was an early celebration :(

Is not working i thought it was working because of web browser cache or some
other cache.

keep working ...

regards,
bruno

--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

bruno.buzzi
Hi,

It seems that the close action is a JS. So the hosts file on server side is
ignored.

If i define in hosts file of the client:
192.168.29.142 gemstoneIP

Then it work ok because the browser do the lookup in the client.

regards,
bruno

--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

Alessandro  Vernet
Administrator
Hi Bruno,

It seems that something is missing, maybe through formatting, in your last
message. What is the URL you had to use? And just to confirm, did that
change indeed solve the issue?

Alex

-----
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|

Re: close.uri valid values

Alessandro  Vernet
Administrator
Have figured this one out, Bruno? Just asking, as I wasn't sure based on your
last message.

Alex

-----
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
--
Sent from: http://discuss.orbeon.com/

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet