Other error with 2016.2.2

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Other error with 2016.2.2

bruno.buzzi
Hi,

There is something that i doing wrong. :) :(

Trying to access:
http://192.168.29.129:8080/orbeon/fr/

Gives the following error: (i think not all exist configuration is removed)
From log:
 opening URL connection {method: "GET", URL: "http://localhost:8080/orbeon/fr/service/persistence/form", Cookie: "JSESSIONID=EBC65809804DBA12DC3EC1F151BA4755", Orbeon-Token: "1a4322c0ec55cc86149d04a3dcf22a0795d09077"}

The strange thing is (excluding version number) everything else looks fine with GemStone/S as the persistence layer.

Still researhing on this .... let you know i find something :)

regards
bruno
Reply | Threaded
Open this post in threaded view
|

Re: Other error with 2016.2.2

bruno.buzzi
Hi,

I think i removed all eXists reference (as stated here: https://doc.orbeon.com/configuration/advanced/production-war.html) but somehow Orbeon still calling eXist only for this page (http://192.168.29.129:8080/orbeon/fr/).
The other Orbeon pages are routed to GemStone/S Rest correctly, still searching what is the error.

2016-12-06 18:01:49,960 DEBUG XFormsServer  -               opening URL connection {method: "POST", URL: "http://localhost:8080/orbeon/exist/rest/db/orbeon/fr?app=&form=", Content-Type: "application/xml", Orbeon-Token: "7444d3c1b8c48a6c6b9d5985679a777936b14ec2"}
2016-12-06 18:01:49,964 DEBUG XFormsServer  -               response {status code: "404"}
2016-12-06 18:01:49,964 DEBUG XFormsServer  -               response headers {Server: "Apache-Coyote/1.1", Expires: "0", Content-Length: "1653", Cache-Control: "no-cache, no-store, must-revalidate", Content-Type: "text/html;charset=utf-8", Pragma: "no-cache", Date: "Tue, 06 Dec 2016 21:01:49 GMT", Set-Cookie: "JSESSIONID=21BC4B3AE6A09B6BFB566E6186B39E9F; Path=/orbeon/; HttpOnly"}
2016-12-06 18:01:49,964 DEBUG XFormsServer  -               response has content
2016-12-06 18:01:49,964 DEBUG XFormsServer  -               saved HTTP state {scope: "session", cookie names: "JSESSIONID"}
2016-12-06 18:01:49,965 DEBUG XFormsServer  -             end opening connection {time (ms): "1063"}
2016-12-06 18:01:49,966 DEBUG XFormsServer  -           end connecting {time (ms): "1067"}
2016-12-06 18:01:49,966 DEBUG XFormsServer  -           start handling result
2016-12-06 18:01:49,966 DEBUG XFormsServer  -           end handling result {time (ms): "0"}
2016-12-06 18:01:49,967 DEBUG XFormsServer  -         end submission {time (ms): "1070"}
2016-12-06 18:01:50,100 ERROR XFormsServer  -         xforms-submit-error - setting throwable {throwable: "
+----------------------------------------------------------------------------------------------------------------------+
|An Error has Occurred                                                                                                 |
|----------------------------------------------------------------------------------------------------------------------|
|xf:submission for submission id: fr-default-submission, error code received when submitting instance: 404             |
|----------------------------------------------------------------------------------------------------------------------|
|Application Call Stack                                                                                                |
|----------------------------------------------------------------------------------------------------------------------|
|----------------------------------------------------------------------------------------------------------------------|
|Exception: org.orbeon.oxf.xforms.submission.XFormsSubmissionException                                                 |
|----------------------------------------------------------------------------------------------------------------------|
|.orbeon.oxf.xforms.submission.XFormsModelSubmission|getReplacer                   |XFormsModelSubmission.java    | 722|
|rg.orbeon.oxf.xforms.submission.RegularSubmission$1|call                          |RegularSubmission.java        | 108|
|rg.orbeon.oxf.xforms.submission.RegularSubmission$1|call                          |RegularSubmission.java        |  78|
|org.orbeon.oxf.xforms.submission.BaseSubmission    |submitCallable                |BaseSubmission.scala          |  89|
|org.orbeon.oxf.xforms.submission.RegularSubmission |connect                       |RegularSubmission.java        | 131|
|.orbeon.oxf.xforms.submission.XFormsModelSubmission|doSubmit                      |XFormsModelSubmission.java    | 453|
|.orbeon.oxf.xforms.submission.XFormsModelSubmission|performDefaultAction          |XFormsModelSubmission.java    | 283|
|.oxf.xforms.event.Dispatch$$anonfun$dispatchEvent$1|apply$mcV$sp                  |Dispatch.scala                | 143|
|.oxf.xforms.event.Dispatch$$anonfun$dispatchEvent$1|apply                         |Dispatch.scala                |  78|
|.oxf.xforms.event.Dispatch$$anonfun$dispatchEvent$1|apply                         |Dispatch.scala                |  78|
|org.orbeon.oxf.xforms.event.Dispatch$              |withEvent$1                   |Dispatch.scala                |  43|
|org.orbeon.oxf.xforms.event.Dispatch$              |dispatchEvent                 |Dispatch.scala                |  77|
|g.orbeon.oxf.xforms.action.actions.XFormsSendAction|execute                       |XFormsSendAction.scala        |  51|
|org.orbeon.oxf.xforms.action.XFormsAction          |execute                       |XFormsAction.scala            |  34|
|rg.orbeon.oxf.xforms.action.XFormsActionInterpreter|runSingleIteration            |XFormsActionInterpreter.java  | 221|
|rg.orbeon.oxf.xforms.action.XFormsActionInterpreter|runAction                     |XFormsActionInterpreter.java  | 157|
|forms.event.EventHandlerImpl$$anonfun$handleEvent$1|apply$mcV$sp                  |EventHandlerImpl.scala        | 256|
Reply | Threaded
Open this post in threaded view
|

Re: Other error with 2016.2.2

bruno.buzzi
Hi,

FIXED :)

My fault i added to properties-local.xml:
<property as="xs:boolean" name="oxf.fr.persistence.exist.active" value="false"/>

Regards,
Bruno
Reply | Threaded
Open this post in threaded view
|

Re: Other error with 2016.2.2

bruno.buzzi
Hi,

Forgot to mention:
http://192.168.29.129:8080/orbeon/fr/

FIXED :)

Also my fault (again) i upgraded XML packages in GemStone/S and that broke on of the REST methods.

Fixed now.

Regards,
Bruno
Reply | Threaded
Open this post in threaded view
|

Re: Other error with 2016.2.2

Alessandro  Vernet
Administrator
Hi Bruno,

Alright… by the time I got to this, you already solved everything. Good!  :) And I've noted the issue you mentioned in another thread with test/library and previous versions not listed on publish; I'll follow-up on this later.

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|

Re: Other error with 2016.2.2

bruno.buzzi
Alex,

I'm about to get into that issue. I think is related to Section Templates when the lateral menu is about to be populated with "Section Templates" but i have to confrm this.

regards
bruno