Orbeon new version 2016.3 up-gradation issue

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Orbeon new version 2016.3 up-gradation issue

udayram
This post was updated on .
Hi All,

Currently we are using Orbeon Forms 2016.1 version. Now we are trying to upgrade new version 2016.3 available in the form. Not able to upgrade successfully getting database connection issue.

Error : Error performing search

Info : orbeon log file attached. orbeon.log

We suspect that we are not able to connect SQL database.

We need solution for resolving this issue.

1. For upgrading new version what steps we need to follow?
2. Need to run any database script? if any pls provide SQL script.
3. Any other configuration need to do?

Below are the error.



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Orbeon new version 2016.3 up-gradation issue

Alessandro  Vernet
Administrator
Hi,

What database are you using? Are you on MySQL or PostgreSQL? Based on the exception in the orbeon.log you attached, it looks like you setup Orbeon Forms CE to use another database, which might explain this.

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Orbeon new version 2016.3 up-gradation issue

udayram
This post was updated on .
Hi Alex,

Thank you for your mail.  We are using  "Microsoft SQL Server". Could you please provide the database scripts which needs to be executed part of release 2016.3 version.

I found certain script in online same we are executed but still some exception is throwing.orbeon.log


https://github.com/orbeon/orbeon-forms/blob/master/form-runner/jvm/src/main/resources/apps/fr/persistence/relational/ddl/sqlserver-2016_2-to-2016_3.sql

Please provide us SQL scripts and steps in detail for upgrading 2016.3 version.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Orbeon new version 2016.3 up-gradation issue

Alessandro  Vernet
Administrator
Got it, then you're most likely having this issue because SQL Server isn't supported by Orbeon Forms CE. If using SQL Server, you need to use Orbeon Forms PE.

While SQL Server had never been supported by Orbeon Forms CE, enough of the code to handle SQL Server was included in earlier version of Orbeon Forms CE for it to work. So, now, you can either:

- Use Orbeon Forms PE (instead of CE), if the pricing is acceptable for your project (see http://www.orbeon.com/pricing), and you can get a 90-day evaluation license to make sure that everything works for you (http://www.orbeon.com/download).
- Switch from SQL Server to an open source database, supported in Orbeon Forms CE, namely MySQL or PostgreSQL.

Would one of those 2 options work for you?

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Loading...