Quantcast

JBoss EAP 7/Wildfly 9 & 10

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

JBoss EAP 7/Wildfly 9 & 10

bwallis42
I was wondering whether any testing of Orbeon 2016.x has been done on the recent versions of the JBoss EAP and Wildfly releases. I am intending to use Wildfly 10 for our next product release and so need Orbeon to work within that platform.

A major change from earlier version is that the embedded tomcat web container is gone, replaced with Undertow. Undertow is somewhat different from Tomcat and I have already hit some issues where our product was using tomcat specific features (Valves are tomcat specific for a start).

So, does anyone have any experiences to share?

thanks
brian wallis...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: JBoss EAP 7/Wildfly 9 & 10

Alessandro  Vernet
Administrator
Hi Brian,

Unfortunately, we didn't get a chance to do testing with WildFly 10. Could you tell us more about the issues you've been seeing? You mentioned Tomcat valves, but Orbeon Forms doesn't depend on Tomcat valves, and is fact is being used on other application servers like WebSphere or WebLogic that also aren't based on Tomcat.

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: JBoss EAP 7/Wildfly 9 & 10

bwallis42
Hi Alex,
  Unfortunately I don't still have the stack trace of the problem I was having. It was a null pointer exception on line 46 of SecureUtils.scala
  private def getHashAlgorithm: String =
    Properties.instance.getPropertySet.getString(HashAlgorithmProperty, "SHA1")
I have updated the version of Orbeon we are using a number of times and had not reconciled changes in the web.xml file (we have our own packaging of the war with a custom web.xml) for a while. I've just done that and the error went away. I think the resource managers were stuffed up.

So, working for the moment and ready for more testing.

thanks
brian...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: JBoss EAP 7/Wildfly 9 & 10

Alessandro  Vernet
Administrator
Hi Brian,

OK, good, and of course, just let us know if the error comes back, and you have a way for us to reproduce it.

Alex

On Sun, Jan 8, 2017 at 1:52 PM bwallis42 <[hidden email]> wrote:
Hi Alex,
  Unfortunately I don't still have the stack trace of the problem I was
having. It was a null pointer exception on line 46 of SecureUtils.scala

I have updated the version of Orbeon we are using a number of times and had
not reconciled changes in the web.xml file (we have our own packaging of the
war with a custom web.xml) for a while. I've just done that and the error
went away. I think the resource managers were stuffed up.

So, working for the moment and ready for more testing.

thanks
brian...


--
View this message in context: http://discuss.orbeon.com/JBoss-EAP-7-Wildfly-9-10-tp4662091p4662095.html
Sent from the Orbeon Forms community mailing list mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].

--
You received this message because you are subscribed to the Google Groups "Orbeon Forms" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Loading...