Checkbox disabled attribute when changing form language

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Checkbox disabled attribute when changing form language

Geert
Hi there,

I have a form with several checkboxes that are enabled/disabled based on the value of other checkboxes.
When I change the language of the form, I seems that the "disabled=disabled" attribute of these 'disabled' checkboxes is removed. The text behind the checkbox is still greyed-out but the checkbox itself is no longer disabled.


Our Orbeon version is 2016.1 and the form was created using the Form builder.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Alessandro  Vernet
Administrator
Hi Geert,

That shouldn’t be case: changing the language shouldn’t change whether checkboxes are disabled or not, so it sounds like this could be a bug. Can you reproduce this with 2016.3? If you can, could you create a minimal example that reproduces the problem, and attach it a response so we can look into it?

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Geert
This post was updated on .
Hi Alessandro,

thank you for the fast reply.

I was able to reproduce the problem in version 2016.3.
Attached you can find a sample that consists of 3 checkboxes.
When you click on checkbox1 and/or checkbox2, you will see that the 3rd checkbox is disabled.
After changing the language, the 3rd checkbox is clickable.

sample_checkbox_issue.xml


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Geert
This post was updated on .
In reply to this post by Alessandro Vernet
Hi Alessandro,

I think I've found the problem.

This behaviour only occurs on checkboxes where the label is translated.
When you have a look a my previous sample and change the label of the 3rd checkbox to 'Option 3' (in both languages) it works just fine.

I suppose this is a bug but do you have any ideas for a 'quick' workaround.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Alessandro  Vernet
Administrator
Hi Geert,

Indeed, good catch! We'll look into it, and I'll follow-up on this thread.

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Alessandro  Vernet
Administrator
Alright Geert, this one is fixed, and the fix will be in 2017.1. Thank you for the report, and I've also included the link to the relevant issue below.

https://github.com/orbeon/orbeon-forms/issues/3237

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Geert
Hi Alessandro, what will be the release date of version 2017.1?

Geert
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Checkbox disabled attribute when changing form language

Alessandro  Vernet
Administrator
Hi Geert, the short answer is: "when it's ready" ;). The longer take on it is that we're in the last stretch of manual testing, and fixing remaining issues as we find them. Hopefully, we'll be able to release 2017.1 in the next couple of weeks.

Alex
--
Follow Orbeon on Twitter: @orbeon
Follow me on Twitter: @avernet
Loading...