Quantcast

Calling session-destroyed.xpl when logout from liferay

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Calling session-destroyed.xpl when logout from liferay

TirupatiReddy
Hi ,

   I deployed my orbeon web application in liferay (tomcat 6.0) portal. I am using CAS for authentication. I am using login and logout from liferay. What I should need to do is call oxf:session-invalidator processor when I logout. I used the below document to call the XPL session-destroyed.xpl that contains the above processor.

 http://www.orbeon.com/ops/doc/reference-listeners

I am using Orbeon Forms 3.7.1 (Developer Release).

The problem is when I login or logout from liferay, it is always calling session-created.xpl and also calling it 5 times.

What I mean is it is calling sessionCreated method from OPSSessionListener class but not the sessionDestroyed method when I logout.

So please let me what I am doing wrong?


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Calling session-destroyed.xpl when logout from liferay

Alessandro Vernet
Administrator
On Thu, Oct 1, 2009 at 4:33 PM, TirupatiReddy <[hidden email]> wrote:

>   I deployed my orbeon web application in liferay (tomcat 6.0) portal. I am
> using CAS for authentication. I am using login and logout from liferay. What
> I should need to do is call oxf:session-invalidator processor when I logout.
> I used the below document to call the XPL session-destroyed.xpl that
> contains the above processor.
>
>  http://www.orbeon.com/ops/doc/reference-listeners
>
> I am using Orbeon Forms 3.7.1 (Developer Release).
>
> The problem is when I login or logout from liferay, it is always calling
> session-created.xpl and also calling it 5 times.
>
> What I mean is it is calling sessionCreated method from OPSSessionListener
> class but not the sessionDestroyed method when I logout.
>
> So please let me what I am doing wrong?
Since you mention Liferay, I have to ask: is this happening only when
you deploy Orbeon Forms as a portlet, or also when you deploy it as a
regular web app (servlet)? If it happens as a web app, can you
reproduce the issue with a plain Tomcat (it is easier for us to
reproduce issues on Tomcat).

Alex
--
Orbeon Forms - Web forms, open-source, for the Enterprise
Orbeon's Blog: http://www.orbeon.com/blog/
My Twitter: http://twitter.com/avernet


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
OW2 mailing lists service home page: http://www.ow2.org/wws
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Calling session-destroyed.xpl when logout from liferay

TirupatiReddy
Thanks Alex for your reply.

It used to work in stand alone environment without liferay.

Now I fixed this one in liferay also. The problem was happending because of the below two lines in liferay-portlet.xml

<private-session-attributes>false</private-session-attributes>
<private-request-attributes>false</private-request-attributes>

when I commented out those two lines, it is working as expected.


Alessandro Vernet wrote
On Thu, Oct 1, 2009 at 4:33 PM, TirupatiReddy <manyamtirupati@yahoo.com> wrote:
>   I deployed my orbeon web application in liferay (tomcat 6.0) portal. I am
> using CAS for authentication. I am using login and logout from liferay. What
> I should need to do is call oxf:session-invalidator processor when I logout.
> I used the below document to call the XPL session-destroyed.xpl that
> contains the above processor.
>
>  http://www.orbeon.com/ops/doc/reference-listeners
>
> I am using Orbeon Forms 3.7.1 (Developer Release).
>
> The problem is when I login or logout from liferay, it is always calling
> session-created.xpl and also calling it 5 times.
>
> What I mean is it is calling sessionCreated method from OPSSessionListener
> class but not the sessionDestroyed method when I logout.
>
> So please let me what I am doing wrong?

Since you mention Liferay, I have to ask: is this happening only when
you deploy Orbeon Forms as a portlet, or also when you deploy it as a
regular web app (servlet)? If it happens as a web app, can you
reproduce the issue with a plain Tomcat (it is easier for us to
reproduce issues on Tomcat).

Alex
--
Orbeon Forms - Web forms, open-source, for the Enterprise
Orbeon's Blog: http://www.orbeon.com/blog/
My Twitter: http://twitter.com/avernet


--
You receive this message as a subscriber of the ops-users@ow2.org mailing list.
To unsubscribe: mailto:ops-users-unsubscribe@ow2.org
For general help: mailto:sympa@ow2.org?subject=help
OW2 mailing lists service home page: http://www.ow2.org/wws


-----
Orbeon Forms - Web 2.0 Forms, open-source, for the Enterprise
Orbeon's Blog: http://www.orbeon.com/blog/
Personal Blog: http://avernet.blogspot.com/
Twitter - http://twitter.com/avernet
Loading...