Quantcast

Caching xForms MOdel/Instance

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Caching xForms MOdel/Instance

Richard Braman

Does Orbeon  have support for caching x forms model and instances?  It seems that with a big model/instance, it takes a while to load each time.  I don’t get the memory error on the first load anymore, but loading a large instance takes a while.

If so can someone provide configuration examples.  Thanks.

 

Richard Braman
Director, Business & Technology Development
Braman Tax Services, Inc.
[hidden email]
http://www.bramantax.com
561.748.4002 (voice)

 



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Caching xForms MOdel/Instance

Erik Bruchez
Administrator
Richard,

OPS (in fact, the XPL engine) has an ojbect cache which, whenever
possible, caches objects in memory instead of recomputing them. However
this is not the end of it.

At the moment there is quite a lot of work going on with XForms instance
in an OPS application. The XForms engine has to load the instance, save
it somewhere while the user is interacting with the XForms engine, etc.
Currently, the state is stored into the HTML page itself. Having a large
XForms instance means that your page will likely be big, even if you
don't have controls bound to much of the instance.

A sound advice is to try to avoid very large XForms instances. Possibly,
when alternative state saving mechanisms are implemented in OPS, such as
saving the state into the session, very large instances can perform better.

-Erik

Richard Braman wrote:

> Does Orbeon  have support for caching x forms model and instances?  It
> seems that with a big model/instance, it takes a while to load each
> time.  I don’t get the memory error on the first load anymore, but
> loading a large instance takes a while.
>
> If so can someone provide configuration examples.  Thanks.
>
>  
>
> Richard Braman
> Director, Business & Technology Development
> Braman Tax Services, Inc.
> mailto:[hidden email]
> http://www.bramantax.com
> 561.748.4002 (voice)


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Loading...